Search found 122 matches

by dazthephot
Sun 02 Aug, 2009 09:52
Forum: Z3 roadster
Topic: MAF sensor
Replies: 19
Views: 1261

Ah i see, i only looked at Bosch because they are the only decent manufacturer i could come across for main OE quality components.

This is the website i looked at: http://www.maf-shop.com/index.php?curre ... ml&cPath=8

thanks guys
by dazthephot
Sat 01 Aug, 2009 18:17
Forum: Z3 roadster
Topic: MAF sensor
Replies: 19
Views: 1261

would you buy a bosch one or just get one from the stealer?
by dazthephot
Sat 01 Aug, 2009 10:26
Forum: Z3 roadster
Topic: MAF sensor
Replies: 19
Views: 1261

MAF sensor

Hi guys, well i've cleaned the MAF sensor and it worked for a short while but now i reckon it's kerknackered. Has anyone tried one of the impoted sensor replacements over the OE ones? symptoms were a host of faults on my peake tool, all lambda related. poor idling, loss of power. when the maf was un...
by dazthephot
Tue 28 Jul, 2009 09:55
Forum: Z3 roadster
Topic: Idling and acceleration 20001.9m43
Replies: 9
Views: 681

CE light lambda faults

well, as a continuation. the ce light is back on and my peake tool says its lambda related, so i guess i'll just swap the 2 probes.

anyone recommend suitable non oem replacements the stealer wants £140 each!

on the upside my maf clean is still working.
by dazthephot
Tue 21 Jul, 2009 12:53
Forum: Z3 roadster
Topic: Idling and acceleration 20001.9m43
Replies: 9
Views: 681

MAF sensor cleaning

This is the link i found, i used digital camera sensor cleaner and a cotton bud.

http://www.louv.tv/cars/m5/MAF/
by dazthephot
Tue 21 Jul, 2009 12:44
Forum: Z3 roadster
Topic: Idling and acceleration 20001.9m43
Replies: 9
Views: 681

All hail to the forum!
Found a link to cleaning the MAF, pulled it out, cleaned it as per instructions, put it back - runs a treat. Cleared the codes now so waiting to see if those pesky lambda faults come back with my CE light.
Many thanks guys, saved me at least £200 squid.
by dazthephot
Tue 21 Jul, 2009 10:33
Forum: Z3 roadster
Topic: Idling and acceleration 20001.9m43
Replies: 9
Views: 681

well well, it just shows you why this forum is a great source of info. i just unplugged the MAF sensor and low and behold the car started straight away, without accelerator and ticked over and revved no problems. i took it off and tried to clean it but there isn't really anything you can do except b...
by dazthephot
Mon 20 Jul, 2009 21:38
Forum: Z3 roadster
Topic: Idling and acceleration 20001.9m43
Replies: 9
Views: 681

i cleaned it today and put it back but no difference. it won't tick over now so i'm gunna unplug the lamda probes one at a time then both and see what happens. i'll keep you posted. my thinking is that if the engine ticks over and revs with the lambda's unplugged then they are faulty. if not, i'll r...
by dazthephot
Mon 20 Jul, 2009 21:29
Forum: Z3 roadster
Topic: Anyone got Airbag Reset tool Near Lincoln
Replies: 2
Views: 301

hi guys, i'm in Hull if that's any good to you and i've got one.
by dazthephot
Sat 18 Jul, 2009 20:05
Forum: Z3 roadster
Topic: Idling and acceleration 20001.9m43
Replies: 9
Views: 681

Idling and acceleration 20001.9m43

Hi guys, here we are again with a poorly zed. This time i'm thinking camshaft sensor, reasons being: will start but won't tick over can't get the revs past 2000 so can't drive it my Peake tool is showing 2 lambda related faults but i'm just not sure, the fault started when i went out one day and had...
by dazthephot
Sun 18 May, 2008 18:37
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

Right then, got the car back thankfully but £989 lighter. The check engine light turned out to be a knock sensor problem which they sorted for free. I think you could be right about the head gasket cos i had a definate airlock in the system. The water level was right up in the expansion tank and wou...
by dazthephot
Thu 08 May, 2008 21:02
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

overheat

just an update. the radiator has had to be replaced as well, as it was blocked??? £989 in total, rad, tstat, w pump, head gasket. is it me or have they just replaced everything cos they don't know what the snag was or have they done right? now the new radiator is wobbly cos they haven't replaced the...
by dazthephot
Mon 28 Apr, 2008 22:51
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

They had the car for one day and called to say they had to do more tests. When they called they said they had been testing the head gasket as they thought the tstat was ok but they weren't sure about the water pump. They then called and said it was definately the head gasket, caused by a failed wate...
by dazthephot
Thu 24 Apr, 2008 18:39
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

Desperately unlucky........yes that's what i thought. I can't help thinking though that the BM techs have fed me a bit of a line cos they can't find the snag. It's not as if i run the engine until there was white smoke everywhere. I guess i'm annoyed cos my engine knowledge ends at straight mechanic...
by dazthephot
Thu 24 Apr, 2008 10:25
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

Oh My God

well try this for size: The thermostat locked shut, this lead to a failed water pump which in turn led to a knackered head gasket which now leads to a £900 bill. I overheated once and turned off the engine straight away surely BMW's are made of tougher stuff - i guess not. I have had a string of bee...
by dazthephot
Wed 23 Apr, 2008 09:53
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

How bizarre, i tried to limp into Stratstone BMW in Hull yesterday and didn't get more than a couple of miles before i had to get the RAC to rescue me. They towed me into BM so they could diagnose the snag. They called after a full day and said they needed more time as they wasn't sure what the prob...
by dazthephot
Sun 20 Apr, 2008 22:24
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

I think i'll start by draining the coolant but i'm not sure how to do that with the heater on, does that mean leaving the ignition on whilst keeping the heater temp dial turned to hot and running the internal blower? if so what does that achieve? i've also seen mention of a bleed screw on the engine...
by dazthephot
Fri 18 Apr, 2008 20:05
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

That's great thanks, and i don't blame you. I've only had the car a year and just done 2500 miles, criminal really but last years floods put the dampner on any open top fun!!
by dazthephot
Fri 18 Apr, 2008 16:36
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

just tried again, the fan comes on when the AC is switched on but before i did that i let the car warm up. the heater is blowing out stone cold air, almost as if the thermostat wasn't even there so i am going to change that first.

has anyone got a paint by numbers method of doing this please?
by dazthephot
Fri 18 Apr, 2008 15:59
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

hi ribs, the fan doesn't come on at all. i am just gunna have a look with the AC on and see if that makes a difference. I can start the car and leave it running, the temp will stay in the middle, but the minute i have done about 10 miles and the engine is hot it overheats at idle. i have never let i...
by dazthephot
Fri 18 Apr, 2008 15:57
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

Hi mrluke, yes i think it is the air conditioner (not the AC) that makes that noise. It usually starts moments after starting the car, lasts for a couple of minutes then goes off. I too usually wait til it's finished before setting off. I've looked at it cos at first i thought it was where the air c...
by dazthephot
Thu 17 Apr, 2008 22:18
Forum: Z3 roadster
Topic: Overheating problem
Replies: 32
Views: 3499

Overheating problem

Hi guys and gals. First of all a warm hello to you all from a new member. My problem is overheating related. I have a 2000 plate 1.9 M43. Topaz blue - lovely, but it has started to overheat when the engine is warm and i am sat at idle. When i am travelling the temp goes down, when stationary i have ...