Search found 566 matches

by colb
Wed 05 Sep, 2012 21:07
Forum: Z3 roadster
Topic: Newbie New Z3 Issues and codes please help
Replies: 45
Views: 4024

Re: Newbie New Z3 Issues and codes please help

Update on my cold start idle problem, whilst still trying to track down the suspected air leak the Disa valve in the intake started clacking which confirmed my suspicion that it was my problem. Fitted a new unit today and then tried a cold start and problem with idle has gone, road test and all is w...
by colb
Sun 02 Sep, 2012 17:09
Forum: Z3 roadster
Topic: Newbie New Z3 Issues and codes please help
Replies: 45
Views: 4024

Re: Newbie New Z3 Issues and codes please help

Laurieh I seem to have the same problem as you at the moment, have been putting right some codes I found just after I bought the car, first one was the Camshaft Sensor, tried a cheap ebay item but code came back bought a BMW sensor then for £90 and that fixed it. Put a new Maf on it then and it tran...
by colb
Sun 02 Sep, 2012 16:53
Forum: Z3 roadster
Topic: Fuel Filter on Z3 1.9i 1999
Replies: 10
Views: 1483

Re: Fuel Filter on Z3 1.9i 1999

Just changed my filter Z3 1.8 1999 and date on that was 1999! Looks like it has never been changed. I would make the observation that the jubilee clips that hold the rubber pipe onto the filter ends were of a type where the screw on them was a security type, screwdriver on them would allow undoing b...
by colb
Wed 15 Aug, 2012 22:25
Forum: Z3 roadster
Topic: P0340 engine code
Replies: 8
Views: 565

Re: P0340 engine code

Monkey I have just been through this with my 1.9, same code as you. Tried a £14 sensor pattern sensor from ebay, code came back so bit the bullet and bought a BMW Sensor current price for mine is £95 they gave me trade price which brought it down to £90. Fitted it and no more code. Also had a bad MA...
by colb
Tue 14 Aug, 2012 18:59
Forum: Z3 roadster
Topic: Lambda exhaust sensors
Replies: 10
Views: 1550

Re: Lambda exhaust sensors

Update on my problem with Long Term Fuel Trim stuck at 19.0 on my Engine Check software. Tried cleaning the Maf which finished it off completely, no longer putting a signal out. Replaced Maf with a pattern part and Bingo, Fuel Trim now responding and car pulls like a train. May still explore the exh...
by colb
Fri 10 Aug, 2012 12:44
Forum: Z3 roadster
Topic: Lambda exhaust sensors
Replies: 10
Views: 1550

Re: Lambda exhaust sensors

Thanks for all the info so far, have had another look at my live data thgis morning. Seems theat long term fuel is stuck at a reading of 19.53 Oxy sensor Bank 2 (after Cat reads 0.43 to 0.49 at tick over and 2000 revs Bank 1 sensor seems ok ranging up and down and gives a good wave form on my scanne...
by colb
Thu 09 Aug, 2012 20:05
Forum: Z3 roadster
Topic: Lambda exhaust sensors
Replies: 10
Views: 1550

Re: Lambda exhaust sensors

Wow some different opnions on the model of my Z3 and what it should have. The options sheet for my car show it was 01 December 1999 production and is a Z3 (Eur) E36 (7) with a M43/TU engine It is badged as a 1.8 although the options sheet shows 1.90 as the displacement. It was first registered in th...
by colb
Mon 06 Aug, 2012 21:28
Forum: Z3 roadster
Topic: Lambda exhaust sensors
Replies: 10
Views: 1550

Lambda exhaust sensors

Have had a couple of codes set on my 1999 1.8 Z3 Pending Code P0340 Camshaft Sensor A circuit Malfunction Bank 1 or Single Sensor I have put in a OEM BMW replacement and so far no codes have returned for this. The second code it set was P0170 Fuel Trim Malfunction Bank 1, it also brought on the Engi...
by colb
Wed 18 Jul, 2012 19:28
Forum: Z3 roadster
Topic: Z3 2.8 stall, loss of power, hard to start
Replies: 19
Views: 4118

Re: Z3 2.8 stall, loss of power, hard to start

Glad you found the problem, code reader will be the best money you ever spent. :lol:
by colb
Thu 05 Jul, 2012 19:57
Forum: Z3 roadster
Topic: Z3 2.8 stall, loss of power, hard to start
Replies: 19
Views: 4118

Re: Z3 2.8 stall, loss of power, hard to start

Dave Getting the codes read will pinpoint your problem if the camshaft sensor(s) are at fault, I think your model has two sensors inlet and exhaust. If either are at fault you will have a stored code. I had a stored code for the camshaft sensor although I hadn't noticed anything wrong with the runni...
by colb
Wed 04 Jul, 2012 20:46
Forum: Z3 roadster
Topic: exhaust problem
Replies: 8
Views: 431

Re: exhaust problem

These people list exhausts for Z3
http://www.onlineautomotive.co.uk/BMW_Z ... ystem.aspx

Colb
by colb
Sat 30 Jun, 2012 22:19
Forum: Z3 roadster
Topic: Z3 Post 2000 Wind Deflector, No Roll Hoops
Replies: 11
Views: 889

Re: Z3 Post 2000 Wind Deflector, No Roll Hoops

Well done for tracking one down, thinking of using some alloy square section instead of using the wood and leather covered version but use the same design, will use to wooden trial pieces as patterns :lol:

Colb
by colb
Sat 30 Jun, 2012 21:27
Forum: Z3 roadster
Topic: Z3 Post 2000 Wind Deflector, No Roll Hoops
Replies: 11
Views: 889

Re: Z3 Post 2000 Wind Deflector, No Roll Hoops

Same situation as lebigmec needing a windbreaker with 70cm mounting pins width for my 1999 1.8 without roll bars. Kept looking on ebay but all the ones turning up were the 75cm type. My car has the sockets installed for the 70cm windbreaker but just couldnt find one. Gave up looking and bought a 75c...
by colb
Wed 27 Jun, 2012 20:04
Forum: Z3 roadster
Topic: Camshaft sensor
Replies: 17
Views: 710

Re: Camshaft sensor

I went through this recently with my 1.9. Had a pending code for the camshaft sensor so took a chance on a cheap replacement on ebay http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItemVersion&item=260937068990&view=all&tid=976781913016 It was a bit of a pain to fit as the diameter was slightly oversize ...
by colb
Tue 26 Jun, 2012 19:35
Forum: Z3 roadster
Topic: New CD/MP3 player
Replies: 3
Views: 310

Re: New CD/MP3 player

Have you considered a single Din Radio/DVD/Satnav with MP3?
Have a look on ebay to see what might be suitable for your interior.

Colb
by colb
Thu 21 Jun, 2012 18:45
Forum: Z3 roadster
Topic: Aerial unit wanted
Replies: 8
Views: 418

Re: Aerial unit wanted

Just been down this route. I had bad reception so removed the aerial and found the top plastic shroud holding the threaded part at the top where the mast screws in had crumbled. The aerial wire connected to the base of the threaded part had also come loose making intermittant contact, hence the bad ...