Page 1 of 1

WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 18:58
by Gordon13
I am trying to locate a lateral load sensor for a Z3.

Its the oblong box under the passenger seat and will have one of these part numbers on it.

34526754289

34526864094

34521166003

34521164454

Hoping someone can help, Gordon

Re: WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 19:27
by Gazza
Could you describe the problems you are having that leads you to think it's that sensor ?

Re: WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 20:07
by Gordon13
ABS and DSC lights on.

Ran a diag on INPA and thats the fault it comes up with.

Are you thinking it may be something else??

Re: WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 20:39
by Gazza
Gordon13 wrote:
Fri 22 Sep, 2017 20:07
ABS and DSC lights on.

Are you thinking it may be something else??
Continuously or random ?

Mine was random and pointed to the Yaw sensor you mentioned, I would get grabbing of the brakes and thumping on the brake pedal without touching the pedal.

I hadn't fixed the problem as it was very random. I did change the discs (due to wear) and all wheel sensors and I've not had the symptoms since.

Re: WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 20:55
by Gordon13
its a permanent fault, cant clear it.

brakes work fine otherwise, I don't think its pad/disc related and there is no pedal thumping/banging that you experienced.

Re: WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 21:32
by Gazza
I would chance changing the FR (driver side) wheel sensor first.

Re: WANTED. lateral load sensor

Posted: Fri 22 Sep, 2017 22:37
by therealdb1
With INPA you should be able to check the yaw sensor.
Bring up the sensor live data on the screen, unbolt the sensor from the floor, and twist the sensor side to side whilst it is still plugged into the car.
You will be able to see the straight ahead position and if it is reacting to sideways movement.
If it does this within the limits shown on the screen you need to look elsewhere.
I am not saying yaw sensors do not fail but being solid state it is rare and it is more likely to be a connection to it or a problem elsewhere blocking its signal.

Re: WANTED. lateral load sensor

Posted: Sat 23 Sep, 2017 08:21
by yalden