Alarm "HELP" please

Tyres, exhausts, suspension, strut braces, air filters, brake pads/rotors and anything else for 'dawn raiders'.

Moderator: Gazza

Post Reply
webby
Joined: Sat 09 Jul, 2005 16:32
Posts: 39

  Z3 roadster 3.0i
Location: leigh on sea

Alarm "HELP" please

Post by webby » Wed 07 May, 2014 11:20

My alarm after a few minutes of it being set goes beeb for a few seconds then the hazard lights start to flash but alarm does not go off. Any ideas anyone? All doors and boot are shut properly.

If I lock door manually I don't get this problem. ????????? My car is a z3 3.0i. Reg 2000

henrycrun
Joined: Wed 18 Apr, 2007 20:48
Posts: 519

  Z3 roadster 1.9
Location: WGC

Re: Alarm "HELP" please

Post by henrycrun » Wed 07 May, 2014 12:39

Can you describe your fob(s) ?

User avatar
BladeRunner919
Joined: Fri 17 Feb, 2012 20:18
Posts: 2220

  Z3 roadster 1.9

Re: Alarm "HELP" please

Post by BladeRunner919 » Wed 07 May, 2014 12:46

It'll be the later alarm, ie not the huge fob.

webby
Joined: Sat 09 Jul, 2005 16:32
Posts: 39

  Z3 roadster 3.0i
Location: leigh on sea

Re: Alarm "HELP" please

Post by webby » Wed 07 May, 2014 13:24

It's the one built into the key.

Does that help?

bertiejaffa
Joined: Fri 26 Jul, 2013 10:28
Posts: 1715

  M roadster S50
Location: Manchester

Re: Alarm "HELP" please

Post by bertiejaffa » Wed 07 May, 2014 14:47

My M has a viper alarm fitted, but I am not sure if or how it is integrated into the OEM one - however it sometimes does the same kind of thing... Everything is shut and locked with the fob but the hazards flash. The fix I use on it is:

Open with the fob
Unlock the boot with the key
Lock the car again with the fob

Dont ask me why, but this works on mine
Here come the girls.....
Image
My //M Refurb
My First Zed Journal

webby
Joined: Sat 09 Jul, 2005 16:32
Posts: 39

  Z3 roadster 3.0i
Location: leigh on sea

Re: Alarm "HELP" please

Post by webby » Wed 07 May, 2014 14:56

Do you need to do that every time?

gookah
Z Register member
Joined: Thu 07 Aug, 2008 10:51
Posts: 2722

  Z3 roadster 2.8

Re: Alarm "HELP" please

Post by gookah » Wed 07 May, 2014 16:40

May be the bonnet switch, just try disconnecting it.
Image

Z3 2.8 Progress Journal (Mine)
Z3 1.9 Sport Progress Journal (Wifey's)

I have an element of 'M-styling' on my car, If that's a good enough reason for the manufacturers to adorn a 320 with the M badge, then its certainly a good enough reason for me..

bertiejaffa
Joined: Fri 26 Jul, 2013 10:28
Posts: 1715

  M roadster S50
Location: Manchester

Re: Alarm "HELP" please

Post by bertiejaffa » Wed 07 May, 2014 18:09

webby wrote:Do you need to do that every time?
Only when it happens, usually the fob is fine and works for ages. I dont know why it happens in the first place
gookah wrote:May be the bonnet switch, just try disconnecting it.
bonnet switch??
Here come the girls.....
Image
My //M Refurb
My First Zed Journal

User avatar
('_')Z3
zroadster sponsor
Joined: Sun 21 Mar, 2010 19:29
Posts: 551

  Z3 roadster 2.0
Location: Lymm

Re: Alarm "HELP" please

Post by ('_')Z3 » Wed 07 May, 2014 19:14

bertiejaffa wrote:
webby wrote:Do you need to do that every time?
Only when it happens, usually the fob is fine and works for ages. I dont know why it happens in the first place
gookah wrote:May be the bonnet switch, just try disconnecting it.
bonnet switch??

As you stand in front of your car it's located above your passenger headlight, it's a bit like a push switch black in colour
Image

webby
Joined: Sat 09 Jul, 2005 16:32
Posts: 39

  Z3 roadster 3.0i
Location: leigh on sea

Re: Alarm "HELP" please

Post by webby » Wed 07 May, 2014 19:36

Thanks for help folks. I'm going to tackle the bonnet sensor tomorrow

bertiejaffa
Joined: Fri 26 Jul, 2013 10:28
Posts: 1715

  M roadster S50
Location: Manchester

Re: Alarm "HELP" please

Post by bertiejaffa » Wed 07 May, 2014 22:13

('_')Z3 wrote:
As you stand in front of your car it's located above your passenger headlight, it's a bit like a push switch black in colour
cool.... whats it do?? The only bonnet switch I know of is the one that opens the bonnet??
Here come the girls.....
Image
My //M Refurb
My First Zed Journal

User avatar
('_')Z3
zroadster sponsor
Joined: Sun 21 Mar, 2010 19:29
Posts: 551

  Z3 roadster 2.0
Location: Lymm

Re: Alarm "HELP" please

Post by ('_')Z3 » Wed 07 May, 2014 22:16

bertiejaffa wrote:
('_')Z3 wrote:
As you stand in front of your car it's located above your passenger headlight, it's a bit like a push switch black in colour
cool.... whats it do?? The only bonnet switch I know of is the one that opens the bonnet??

Presumably stops anyone from lifting the bonnet to tamper with anything without the alarm going off
Image

User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 11:35
Posts: 9984

  Z3 roadster 1.9
Location: Cheshire

Re: Alarm "HELP" please

Post by Robert T » Thu 08 May, 2014 01:23

Interesting, as I have the later alarm on mine and it has never beeped. It either sounds properly or not at all. The LED flashes to indicate a sensor problem. Locking with the key does not set the alarm (the immobiliser is separate and arms itself when the key is removed from the ignition).

You need to check all the sensors. Doors, boot, bonnet switch, stereo anti-theft switch, interior movement sensors, and tilt switch. The latter is in the boot behind the left-hand trim in the bottom of the well - the don't like getting wet.

Cheers R.

Sent from my GT-I9300 using Tapatalk
Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image

Jonco
Joined: Sat 04 Jun, 2011 08:24
Posts: 382

  Z3 roadster 1.9
Location: Cheshire

Re: Alarm "HELP" please

Post by Jonco » Thu 08 May, 2014 09:21

('_')Z3 wrote:
bertiejaffa wrote:
('_')Z3 wrote:
.......... The only bonnet switch I know of is the one that opens the bonnet??
Presumably stops anyone from lifting the bonnet to tamper with anything without the alarm going off
Agree with RobertT's comment - if you are looking at bonnet switch this may help http://www.zroadster.net/forum/viewtopi ... 18&t=15166

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest