Brakepad wear sensor

Repository of 'how to do' articles relating to the Z3 and M roadster/coupe

Moderator: Gazza

Locked
swamper
Joined: Thu 13 May, 2010 18:14
Posts: 1866

  M roadster S50
Location: Mossley

Brakepad wear sensor

Post by swamper » Fri 19 Nov, 2010 13:59

thought id have a look at the sensors and found the brake wear sensor in quite bad shape.......



iv just unplugged it and the brake warning light came on ......so it must be working.................. :puzzle:

plugged wear sensor back in and now the brake warning light stays on...........will this need a reset anyone?

just found this...........and it works :wink:

BMW BRAKE WARNING LIGHT RESET

Make sure that you replaced the sensor and the brake pads if you did not replace the sensor or pads this will not work. Turn the key to position two (when all of the inspection lights are lit), leave it in this position and leave your driver’s door open a few seconds (between 15 to 90 seconds depending on your car) and it magically resets. If that did not work turn the key to position two and push down on the brake then turn the key off and check to see if it turns off (door must also be open). If this still does not work press down on your brake (hold it pushed down) and turn the key to position two and wait until it turns off. If none of these work please go back and check that you installed the sensor correctly.
the badness makes me do it...!

Image

Locked

Who is online

Users browsing this forum: No registered users and 2 guests