Been a bit busy on the "M" since I got it....

For the M Powered Z4 derivatives

Moderator: Gazza

Post Reply
User avatar
CockneyPlayboy
Joined: Wed 13 Jul, 2005 14:34
Posts: 29

  Z3 roadster 2.8
Location: Hazard County

Been a bit busy on the "M" since I got it....

Post by CockneyPlayboy » Tue 29 Jul, 2014 13:31

SO - after my mammouth 18hr detailing and swirl reducing session on the paint the project moves forward........

Image

Image

My plate transfer is finally done..... the Eibach Springs are also now in place, (25mm drop at the front and 10mm at the rear) so the stance is much better

Image

.............and FINALLY the new shoes are on!

I plumped for Avante Garde Memphis as they have a look of the CSL rims about them whilst still retaining their own individuality to step is aside from them. See what you think anyway.

PLEASE NOTE, I am still awaiting a small set of spacers for the rear to get them to sit just right/perfect.

Image

Image

Image

Image

Image

Image

Next up is the Zorst, although I really havent decided which route to go yet so I will wait and see. I have the front bumper being repainted too in order to get it spotless and immaculate due to the many stone chips it seems to have hoovered up along its years! BUT its looking a bit more like a "me car" now so I am happy.
Image

User avatar
c_w
Joined: Thu 19 Aug, 2004 17:50
Posts: 4032

  M roadster S50

Re: Been a bit busy on the "M" since I got it....

Post by c_w » Tue 29 Jul, 2014 17:14

Nice wheels. Like concave TSW Venoms! :D

User avatar
CockneyPlayboy
Joined: Wed 13 Jul, 2005 14:34
Posts: 29

  Z3 roadster 2.8
Location: Hazard County

Re: Been a bit busy on the "M" since I got it....

Post by CockneyPlayboy » Mon 04 Aug, 2014 10:10

SO... decided to "M-up the Grille" a little...

Nicked the wifes hairdryer, got a surgical scalpel, had the relevant coloured adhesive tape and a steady hand!

Image

Image

Image

Unfortunately............. the hairdryer paid a price.... namely me forgetting I'd tucked it under the car and I drove over it.... was gonna tell the Mrs but she looked to happy in her ignorance of the fact......! :lol:

Image


Took another couple of shots at the weekend next to my other pride and joy......

Image

Image

Image

Image
Image

User avatar
pingu
Joined: Fri 30 Apr, 2004 17:01
Posts: 3337

  M roadster S50

Re: Been a bit busy on the "M" since I got it....

Post by pingu » Mon 04 Aug, 2014 11:14

Put the hairdryer under her cushion and blame her :twisted: .

Love the campervan :D .

Also, I'm tempted to do the grille lines. As it's easily reversible, no harm done if I don't like it.
Pingu

User avatar
CockneyPlayboy
Joined: Wed 13 Jul, 2005 14:34
Posts: 29

  Z3 roadster 2.8
Location: Hazard County

Re: Been a bit busy on the "M" since I got it....

Post by CockneyPlayboy » Mon 04 Aug, 2014 11:52

pingu wrote:......

Also, I'm tempted to do the grille lines. As it's easily reversible, no harm done if I don't like it.

Precisely! :wink:
Image

User avatar
CockneyPlayboy
Joined: Wed 13 Jul, 2005 14:34
Posts: 29

  Z3 roadster 2.8
Location: Hazard County

Re: Been a bit busy on the "M" since I got it....

Post by CockneyPlayboy » Fri 17 Oct, 2014 12:38

ITS HERE!!!!!!!

The RPI exhaust I paid so much for and waited so long for has docked, cleared customs, and arrived in my living room!!!!


Image

Image

Image

Image


Gonna be awesome!
Image

Joycey
Joined: Mon 11 Jul, 2011 23:15
Posts: 278

  M roadster S52
Location: Basingstoke

Re: Been a bit busy on the "M" since I got it....

Post by Joycey » Sat 18 Oct, 2014 08:06

A friend i know has that system on his M, the noise is incredible. Look forward to hearing it at some meets.

Lee
Image

User avatar
CockneyPlayboy
Joined: Wed 13 Jul, 2005 14:34
Posts: 29

  Z3 roadster 2.8
Location: Hazard County

Re: Been a bit busy on the "M" since I got it....

Post by CockneyPlayboy » Thu 26 Mar, 2015 16:41

Joycey wrote:A friend i know has that system on his M, the noise is incredible. Look forward to hearing it at some meets.

Lee
Yeah its pretty thunderous! Defo the loudest i've ever had on any motor!
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest