Hello forum and a few problems

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
easisatman
Joined: Sat 17 Sep, 2011 10:49
Posts: 27

  Z3 roadster 1.9
Location: Barcelona
Contact:

Hello forum and a few problems

Post by easisatman » Sun 18 Sep, 2011 18:42

Hi Forum I have just joined great looking forum.
My wife has just bought a 97 Z3 which has a few problems The first one I fixed Yesterday a broken Handbreak cable which i thought was a half hour job!!! the outer cable which goes into the brake caliper was siezed no amount of hitting moved it so i had to cut the outer cable close to the caliper and drill the rest out , after 4 hours job done. reading the forum I came across a great thread about seats rocking By Aceman yep we defo have that problem and already have ordered those from Aceman so hopefully that problem will be solved when they arrive and me fitting them of course!!so that leaves the central locking blowing a fuse when you try and unlock the doors with the key- Any ideas? also the air bag light is on does anyone know how to get this off? and the power hood powers up and down when it feels like it, but I have read a few threads about micro switches so i will investigate. Any advise will be greatly appreciated
Easisatman
Spain

User avatar
aceman
Joined: Sun 01 Jun, 2008 12:16
Posts: 1478

  M roadster S50
Location: Wakefield

Re: Hello forum and a few problems

Post by aceman » Sun 18 Sep, 2011 19:01

easisatman wrote:Hi Forum I have just joined great looking forum.
My wife has just bought a 97 Z3 which has a few problems The first one I fixed Yesterday a broken Handbreak cable which i thought was a half hour job!!! the outer cable which goes into the brake caliper was siezed no amount of hitting moved it so i had to cut the outer cable close to the caliper and drill the rest out , after 4 hours job done. reading the forum I came across a great thread about seats rocking By Aceman yep we defo have that problem and already have ordered those from Aceman so hopefully that problem will be solved when they arrive and me fitting them of course!!so that leaves the central locking blowing a fuse when you try and unlock the doors with the key- Any ideas? also the air bag light is on does anyone know how to get this off? and the power hood powers up and down when it feels like it, but I have read a few threads about micro switches so i will investigate. Any advise will be greatly appreciated
Easisatman
Spain
Hi Easisatman,

Welcome aboard always good to help a fellow zedder out.

with regard to your central locking have a look in the wiring going between the boot lid and body as it is prone to breaking, also check the wiring going to the doors although the boot wiring is more common. The microswitch in the hood is the likely cause of your intermittant hood issues although also check the brake light switch as this can cause problems also. The airbag light on is a common occurance aswell usually caused by the wiring under the seat to the seatbelt pre-tensioners coming loose or rubbing on the seat mechanism resulting in the dash light coming on indicating a fault. There are several reset devices available depending on what you really want ranging from just airbag reset tools to full diagnostic device. Have a search on fleabay for PEAK Tools as they are quite popular or there are various Carsoft options to run on a laptop with the appropriate adapter leads.

Once agin welcome and I hope you enjoy your new Z experience you should have the weather for some good top down driving living in Spain. :D
Aceman

Arctic Silver '98 Z3M

Previously;
Bright RED '99 Z3 2.8

Rocking seats ? You need seat bushes click HERE

easisatman
Joined: Sat 17 Sep, 2011 10:49
Posts: 27

  Z3 roadster 1.9
Location: Barcelona
Contact:

Post by easisatman » Sun 18 Sep, 2011 19:36

Many Thanks Aceman I will look into those and report back. :D

easisatman
Joined: Sat 17 Sep, 2011 10:49
Posts: 27

  Z3 roadster 1.9
Location: Barcelona
Contact:

Post by easisatman » Mon 19 Sep, 2011 22:55

Yep you were right aceman It was the cable going through the boot the outer insulation was broken on a couple of wires, taped Them up and "Deep joy" no fuse blowing but could not use the remote key to unlock and lock but found a thread http://www.zroadster.net/forum/viewtopi ... highlight= on reprogramming the key by pressing the unlock button while pressing the lock button 3 times worked a treat many thanks
easisatman :colourful:

Jamezee
Joined: Sat 21 Feb, 2009 23:46
Posts: 1411

  Z3 roadster 2.2i
Location: Royston Vasey

Post by Jamezee » Wed 21 Sep, 2011 01:28

Welcome to Zee forum easisatman :)
Opinions are like assholes, everybody has one. Harry Callahan.

BMW dust caps x 4 (replica)
Little Tree Air Freshener-Vanillaroma (now worn out and in the bin)
2006 AA road atlas (with the latest safety cameras)

Bill-
Joined: Sat 21 May, 2011 11:57
Posts: 305

  blank.gif
Location: Brands hatch

Post by Bill- » Wed 21 Sep, 2011 01:34

Great news, this is such a brilliant site :D

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests