Intermittent radio reception - almost none existent

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
Lewy
Joined: Mon 22 Oct, 2012 18:34
Posts: 203

  Z3 roadster 2.8
Location: Wolverhampton

Intermittent radio reception - almost none existent

Post by Lewy » Sun 16 Oct, 2016 21:07

Hi fellow Zedders!

I'm hoping I have a common issue which is easy to fix.

I really struggle to get any reception for my radio and wondered if this is usually a problem in the boot area or if its behind the centre console.

I'll be stripping out the interior over the winter and could run a brand new cable but if there's an easy fix Id be really keen to learn.

Thanks in advance

Sent from my SM-G925F using Tapatalk
Image

mrscalex
Joined: Fri 13 Mar, 2015 09:14
Posts: 795

  Z3 roadster 1.9

Re: Intermittent radio reception - almost none existent

Post by mrscalex » Mon 17 Oct, 2016 00:43

What station do you listen to? I've had a lot of problems with Radio 2 (what else is a Z3 owner going to listen to really) this week and thought it might be their transmitters.

Just a long shot thought.
ImageImage
1999 Z3 1.9 Boston Green (Dimitri) - My brother's car owned from new and restored by me
2001 Z3 2.2 Topaz Blue (Trudy) - My car rebuilt from a write-off
2002 Z3 2.2 Titan Silver (Okus) - Project car waiting for a new engine
2001 Z3 2.2 Topaz Blue (Debra) - Donor car/breaker
1998 Z3 1.9 Boston Green (Allsworth) - Donor car/breaker now gone to Z3 heaven
Always happy to try and help with spares :)

siwilson
Joined: Fri 19 Jun, 2009 10:54
Posts: 782

  M roadster S54
Location: Horley

Re: Intermittent radio reception - almost none existent

Post by siwilson » Mon 17 Oct, 2016 08:18

Do you have a factory radio or has it been replaced with aftermarket? If aftermarket then its quite possible the antenna amplifier (in the boot) power feed is not connected to the back of the head unit. Aftermarket head units tend to have two wires that are not connected into the ISO connector. One for amplifier power and the other for antenna remote. Another option is the antenna amplifier at the base of the antenna. These do fail.

The first thing I would do is pull the head unit to see if everything is connected properly. Then check you are getting power to the antenna amplifier.
2001 M roadster S54 Laguna Seca Blue

User avatar
colb
Joined: Sat 05 May, 2012 23:46
Posts: 566

  Z3 roadster 1.8 TU
Location: Newport South Wales UK

Re: Intermittent radio reception - almost none existent

Post by colb » Mon 17 Oct, 2016 17:04

Take the whole unit out and unscrew the top underneath is a very small wire check to see if it is connected or got a bad joint. Its the feed to the mast. Mine had disintegrated and caused the fault you are having. I managed to solder a new wire in and that restored reception.
Colb
1999 BMW 1.8 Z3
1998 Honda Deauville NT650V

Lewy
Joined: Mon 22 Oct, 2012 18:34
Posts: 203

  Z3 roadster 2.8
Location: Wolverhampton

Re: Intermittent radio reception - almost none existent

Post by Lewy » Thu 20 Oct, 2016 12:19

Hi all, thanks for your input. Back of the h/u is definitely plugged in correctly.

Looks like colb has had the same issue. I'll give it a whirl at the weekend and post back results :)

Sent from my SM-G925F using Tapatalk
Image

User avatar
Brian H
zroadster sponsor
Joined: Tue 16 Dec, 2008 19:55
Posts: 2502

  Z3 roadster 3.0i

Re: Intermittent radio reception - almost none existent

Post by Brian H » Thu 20 Oct, 2016 12:55

Hi Lewy,

You posted about this a while back viewtopic.php?f=5&t=37886&hilit=radio#p351948 I assume the following link did not help?

viewtopic.php?p=211526#p211526

Cheers

Brian

Lewy
Joined: Mon 22 Oct, 2012 18:34
Posts: 203

  Z3 roadster 2.8
Location: Wolverhampton

Re: Intermittent radio reception - almost none existent

Post by Lewy » Thu 20 Oct, 2016 19:42

Thanks Brian, given I've slept since then its well and truly left my memory. I'll take a look. Cheers.

Sent from my SM-G925F using Tapatalk
Image

Lewy
Joined: Mon 22 Oct, 2012 18:34
Posts: 203

  Z3 roadster 2.8
Location: Wolverhampton

Re: Intermittent radio reception - almost none existent

Post by Lewy » Thu 20 Oct, 2016 19:43

Thanks Brian, given I've slept since then its well and truly left my memory. I'll take a look. Cheers.

Sent from my SM-G925F using Tapatalk
Image

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 9 guests