Self emptying wash bottle....

UK forum for general and technical discussion about the Z4 roadster and Z4 Coupe

Moderator: Gazza

Post Reply
Haggispeed
Joined: Wed 14 May, 2008 23:12
Posts: 9

  Z4 coupe 3.0si

Self emptying wash bottle....

Post by Haggispeed » Fri 17 Dec, 2010 12:26

Since the last big freeze I seem to have a problem with the windscreen wash bottle, it just keeps emptying, when the dash light was on for a while I thought it was just still frozen but then discovered it was empty having not long topped it up with screenwash. So removed it, which is a bit fiddly, (three wiring connections and two water pipes), to see if it had split in the freeze but all was OK. refilled and left on the drive for a few hours, checked again and no drop in level, drove about ten miles and used the washers, worked fine, left in the car park at work, came back at end of day and behold an empty wash bottle again ! no signs of puddles on the ground to indicate where it might be going. So anyone ever had anything similar ? Problem is the front headlight wash pipes disappear into the front cowling and bumper so difficult to check all that out without some major removals so it could be off to the BMW garage for this job

JamesCB
Joined: Wed 08 Dec, 2010 11:03
Posts: 10

  blank.gif

Post by JamesCB » Tue 04 Jan, 2011 11:42

Could it be that it only empties when you use the spray, i.e. opens something that lets all the fluid out?

Might be worth testing it overnight in a garage if you can, to see if fluid leaks out when you just leave it for a longer time.

User avatar
kruisn
Joined: Sat 22 Oct, 2005 23:28
Posts: 395

  Z3 roadster 3.0i
Location: Auckland,New Zealand

Post by kruisn » Tue 04 Jan, 2011 21:23

Had the same problem with my car even though it had only done 19000ks
It had worn a very small hole in the moulding joint at the bottom of the container. A little carefull heat with the solder iron welded it up sufficiently.
No trouble since.
Happy Zding
Don't drink and drive home -
Take the Zd and fly home -

Haggispeed
Joined: Wed 14 May, 2008 23:12
Posts: 9

  Z4 coupe 3.0si

Post by Haggispeed » Thu 06 Jan, 2011 10:14

Thanks for the suggestions. Haven't found the leak as yet but have now determined that the leak is something to do with the headlamp washer part of the system. No leaks from the bottle if filled and left, no leaks if the washers are used without the headlights on (i.e. just the screen wash) but if the washers are used with the lights on and therefore using the front bumper jets then it loses its water within a few hours. So either I've got a cracked pipe or fitting or something is wrong with the valve for the front jets, not really sure. Can't really get to any of the pipework at the moment but will have it up on ramps this weekend for a better look.

tonym
Joined: Thu 03 Sep, 2009 21:15
Posts: 90

  Z4 roadster 2.5i
Location: Guildford

leaking washer bottle

Post by tonym » Wed 19 Jan, 2011 21:24

:Had the same problem except the wshher fluid was leaking out beneath the front bumper. contacted my excellent bmw independant and he kner immediately that it was the nearside headlamp washer jet. not related to the cold weather as they can go any time Fortunately i have warranty direct and most of the cost is being addressed by them.|

Haggispeed
Joined: Wed 14 May, 2008 23:12
Posts: 9

  Z4 coupe 3.0si

Post by Haggispeed » Fri 21 Jan, 2011 06:37

thanks TonyM I didn't get the chance to crawl around in the dirt to check it out and plan to get it over to my local Indy in Warrington asap. No maintenance cover on mine though :(

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest