Cinders

Details of how to register as a zroadster.net user, plus tips on day-to-day usage

Moderator: Gazza

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Mon 14 Mar, 2016 17:46

deni2s wrote:I don't know if it's possible with your ECU, but with MS41 I could use free software RomRaider with OBD2 data cable you already have which allows to log various data from car sensors in real time and check what's happening. Like air flow, fuel trim, coolant temp, etc. And then I could look at the tables in ECU and try to understand. Maybe some engine temp sensor is not working correctly and ECU tries to enrich the fuel all the time because of that. But of course, you need some experience and understanding how ECU tables are related to the car sensors and engine.
I can look at the sensors in real time, but everything looks as it should and it is a bit limited with this engine. Bearing in mind how much the car was sitting around along with the blocked CCV hose and sooty exhaust I am hoping there's a bit of carbon that needs clearing out. Booked it in for Wednesday morning and when I spoke to the garage on the phone they seemed pretty good and checked what I had already done and what the symptoms were so I wasn't going to waste my money. :thumb:

deni2s
Joined: Mon 25 Mar, 2013 22:02
Posts: 747

  Z3 roadster 2.8

Re: Cinders

Post by deni2s » Mon 14 Mar, 2016 19:39

Ok, if you say fuel injector pulse widths are according to ECU tables, then I am guessing that injectors are bad or misaligned cams. But that's just wild guess. Others things should throw some error codes IMHO.

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Tue 15 Mar, 2016 08:11

deni2s wrote:Ok, if you say fuel injector pulse widths are according to ECU tables, then I am guessing that injectors are bad or misaligned cams. But that's just wild guess. Others things should throw some error codes IMHO.
I haven't looked at them for a couple of weeks, but I don't think the fuel injector pulse widths were shown :shrug. The garage I'm going to just happens to be a performance place with rolling road etc and as part of the cost they will check the car over so hopefully they'll find the problem if the Terraclean doesn't....otherwise I could be looking for the cause for some time! :roll:

deni2s
Joined: Mon 25 Mar, 2013 22:02
Posts: 747

  Z3 roadster 2.8

Re: Cinders

Post by deni2s » Tue 15 Mar, 2016 09:02

They are not shown in INPA, but I can see them with RomRaider software - it writes the log in real time and you can analyse it later, probably there are other options too. But you have different ECU, so I can't help much here.

bertiejaffa
Joined: Fri 26 Jul, 2013 10:28
Posts: 1725

  M roadster S50
Location: Manchester

Re: Cinders

Post by bertiejaffa » Tue 15 Mar, 2016 13:07

What MPG do you reckon you are actually getting?
Here come the girls.....
Image
My //M Refurb
My First Zed Journal

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Tue 15 Mar, 2016 19:01

bertiejaffa wrote:What MPG do you reckon you are actually getting?
I use Fuelly so I know exactly what I get- 28mpg driving like a granny on tranquilisers and 22mpg driving in a semi-spirited fashion. :shock:

deni2s
Joined: Mon 25 Mar, 2013 22:02
Posts: 747

  Z3 roadster 2.8

Re: Cinders

Post by deni2s » Tue 15 Mar, 2016 20:01

I am getting almost 30 mpg in tuned manual 2.8 with normal driving and around 25 mpg in stock automatic 2.8.

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Thu 17 Mar, 2016 17:23

I filled up just before going or the Terraclean and got 24mpg :(, but there was a bit of mucking about with the engine during this tankful and I also changed the CCV hose and MAF boot very recently so would expect an increase just due to that. They did the clean and didn't mention anything untoward and then checked the car over afterwards and added a few things to my list-

There is an earth strap up the side of the fuel tank that has rotted off and needs replacing.
The fuel tank strap has taken a knock on a road hump or similar at some point and it really needs replacing as it's rusty anyway.
There is some underseal starting to come away near the sill.

As I want to drop the rear subframe off and sort out some other rusty bits I'll do all of the above at the same time.

One thing they did fix for me though was my sticky accelerator pedal. I had 'repaired' it a few weeks back by slightly tightening the throttle cable, but this problem returned. What they did was to loosen the side of the throttle body where the cable joins and turn it slightly then re-tighten it. Apparently this is quite a common problem that needs adjusting after cleaning the throttle body. The accelerator pedal now feels as it should. The car doesn't really feel any smoother as it was quite smooth before the clean, but I'll see what happens with the fuel consumption. :shrug

bertiejaffa
Joined: Fri 26 Jul, 2013 10:28
Posts: 1725

  M roadster S50
Location: Manchester

Re: Cinders

Post by bertiejaffa » Thu 17 Mar, 2016 20:38

most cars our age benefit from a new throttle cable anyway - the difference in bite and response is very notiable and at £25 ish from BMW (memory not what it was) its not an expensive job
Here come the girls.....
Image
My //M Refurb
My First Zed Journal

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Thu 17 Mar, 2016 21:13

bertiejaffa wrote:most cars our age benefit from a new throttle cable anyway - the difference in bite and response is very notiable and at £25 ish from BMW (memory not what it was) its not an expensive job
I did have a new cable ready to replace the existing one, but there was nothing wrong with the cable itself- just the bit it attaches to- so I took it back for a refund.

bertiejaffa
Joined: Fri 26 Jul, 2013 10:28
Posts: 1725

  M roadster S50
Location: Manchester

Re: Cinders

Post by bertiejaffa » Thu 17 Mar, 2016 22:35

They stretch over time - for me it was shown with a stuggling bite point, not very noticable but just enough to make you semi-think about it, and make other people complain about it. The cable looked perfect but it made such a difference to the response.
Here come the girls.....
Image
My //M Refurb
My First Zed Journal

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Fri 25 Mar, 2016 12:58

So, back to my fuelling issues. I took the car for a run up to Rutland Water last Sunday and it ran sweetly with the fuel consumption looking better after the Terraclean. Alas I fear this isn't the end :(. There was very little traffic on my drive and I took it easy on more or less motorways, but when I was near home I could again smell fuel when braking into roundabouts. A week of work has got in the way since, but this morning I have done some investigation.

Starting with what the mechanic told me at the Terraclean place that I had slightly too much oil in my engine. What he didn't do was smell it, which I have now corrected- yep it smells of petrol and is quite thin :bawl:. I have carried out a compression test with no problems identified- all 4 cylinders are between 180 and 195 psi. :) Hopefully someone can confirm this is ok for my engine?

One thing I did notice was the difference in my spark plugs, bearing in mind I have blow-by going on (no black smoke or petrol coming out of the exhaust) it was interesting to look at the plugs. These were in new about 750 miles ago:

ImageIMG_20160325_104150751

Note that cylinders 1 and 2 are very dark and wet, cylinder 3 slightly drier and cylinder 4 very dry. Which is interesting as the fuel pressure regulator is next to cylinder 1 and it is this that I suspect is faulty as my fuel isn't shutting off on the over-run. Can anyone confirm this 'logic' please :shrug?

When it comes to the FPR this is mine

ImageIMG_20160325_084112618

It's secured with a circlip and the manual says after taking this off it should just twist and pull off, but I can't seem to get it off. It twists and I've applied a reasonable amount of pressure to try and get it off but I don't want to force it. Is there a knack to this??

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Tue 29 Mar, 2016 19:26

Today I bit the bullet and booked Cinders in to a local injection specialist for a check over as it'll probably end up cheaper than trying to hunt down the problem myself :shrug. Besides which I suspect an injector or three might be at fault anyway so they would end up having to be checked.

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Thu 07 Apr, 2016 15:44

The injection specialist had the car for a couple of days, but the injectors were never inspected. Instead what he found was that the CCV, that I bought from BMW, was "blown apart" and not working. He then carried out an emissions test, followed by a road test then the emissions again and he got no smell of fuel and the emissions were 12 parts per million, which is apparently very good :D. As there is no starting, idling or running issues he didn't waste his time and my money taking the injectors apart. He couldn't replicate the smell of fuel either, and I haven't had it since. He couldn't explain the wet plugs though....anyone?? :shrug

Today I've put it back up on stands to check for brakes binding and have found that my nearside is binding quite badly, so it looks like this is going to be my low MPG cause and the faulty CCV was causing the fuel smell. I'll change the oil and filter to get rid of the contaminated stuff.

In the general spirit of Cinders, when I tried to sort the brakes out I found some play in the wheel bearing :head: and added to a sticky caliper the handbrake mechanism has given in to the rusty backing plate and is loose in the hub :head:. As I can't get the hub off I've booked it in to another garage next week to have both bearings and backing plates replaced.

In the meantime, while it's up on stands I think I'll clean some rust off and start Hammeriting some of the rusty bits to impress the MOT tester :lol:

User avatar
Southernboy
Joined: Thu 07 Oct, 2010 13:39
Posts: 6312

  Z3 roadster 3.0i
Location: Johannesburg

Re: Cinders

Post by Southernboy » Fri 08 Apr, 2016 09:44

Oily spark plugs are an indication of worn valve stem seals. Replacing them is a huge exercise - requires removing the cylinder head which you really don't want to do unless you're going to do a complete head restoration. The seals are visible if the valve / head cover is removed. They sit right at the base of each valve. Perhaps remove the cover, and check them all to make sure they're seated properly, and that none of them have popped off their little posts they clip onto. You will need to wipe away the oil in the bottom to see what's happening there... If you read the page below, you will see the point made about "smoke" at start up and deceleration... Perhaps check these references by taking a drive and checking for any smoke on deceleration... The engine will need to be at running temp for it to show - also, you will need to be at some speed and allow the deceleration to occur with the car in gear so the motor is still revving as you decelerate.

Image
"Normal is overrated"
Image

Z3 Upgrades and Additions

Wookee
Joined: Thu 10 Dec, 2015 19:45
Posts: 166

  Z3 roadster 1.9i
Location: Herts

Re: Cinders

Post by Wookee » Fri 08 Apr, 2016 13:02

Thanks for the tip, but I have no symptoms of this as there is no smoke at any time and no oil consumption to speak of. In fact, the oil level increased :shock: , but that was due to the fuel addition. The CCV has been changed and oil and filter has been done now. I won't be driving it too much for a week or so as it needs a bit of fettling then off to have the wheel bearings replaced, then I'll see if there is any improvement.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests