any ideas

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
mickdev
Joined: Thu 18 Feb, 2016 17:38
Posts: 39

  Z3 roadster 1.8 TU

any ideas

Post by mickdev » Sat 13 Jan, 2018 10:58

Before I put the Z3 away for winter I was having an intermittent problem where if I turned the engine off and then tried to restart the car the dash would go completely dead and the car would not start no noises at all, completely dead.
I checked the battery terminals all seemed fine.
I went to the car to take it out for a run yesterday,the battery had gone flat the week before so I charged it up, she started fine, I rest the clock from the dead battery the previous week, took the car for a run and called for some petrol when I tried to restart the car at the station dead completely for the first try and then started fine.
I put the car away and went to it this morning , central locking fine, but when I got in the car the clock was 35 minutes behind time and the radio code needed putting in so overnight I had lost power for some reason, any ides as it is doing my head in.
cheers
in advance

andy & fonz
Joined: Tue 28 Jul, 2015 18:35
Posts: 48

  Z3 roadster 2.2i

Re: any ideas

Post by andy & fonz » Sat 13 Jan, 2018 11:25

Hi
how old is your battery? maybe taking a charge but not holding it, might be worth having it checked, also remove and clean as many earths as you can i.e battery and in the engine bay.

User avatar
Gazza
Site Admin
Joined: Tue 04 Oct, 2005 21:58
Posts: 9220

  M roadster S54
Location: East London/Essex

Re: any ideas

Post by Gazza » Sat 13 Jan, 2018 11:40

As suggested, battery not taking a full charge. I had similar in that the battery would charge just enough to start the car but the next start was dead.
Gazza

"Understeer is when you hit the wall with the front of the car, oversteer is when you hit the wall with the rear of the car. Horsepower is how fast you hit the wall and torque is how far you take the wall with you"

S54 M roadster Image, BMW Z1, BMW M3 CSL, Mustang Fastback

ImageImage

User avatar
colb
Joined: Sat 05 May, 2012 23:46
Posts: 604

  Z3 roadster 1.8 TU
Location: Newport South Wales UK

Re: any ideas

Post by colb » Sat 13 Jan, 2018 19:27

Sounds very much like a problem I had, noticeable after a night run using headlights, next day flat battery. Checked alternator output and found it was only pushing out 12 volts. Replaced alternator charged battery up and checked alternator output which was restored to over 14 volts when engine running. Still have the old alternator and will get around to putting a new diode brush pack into it, they can be obtained from ebay for sub £30. Replacement alternator was around £80. Check the make and model number of your alternator there were a few different types fitted over the model range and years.
Colb
1999 BMW 1.8 Z3
1998 Honda Deauville NT650V

mickdev
Joined: Thu 18 Feb, 2016 17:38
Posts: 39

  Z3 roadster 1.8 TU

Re: any ideas

Post by mickdev » Wed 24 Jan, 2018 13:14

New battery sorted it !

Post Reply

Who is online

Users browsing this forum: Benw123 and 8 guests