Search found 9672 matches

by Robert T
Fri 14 Jun, 2019 14:39
Forum: Z3 roadster
Topic: Roof issues
Replies: 15
Views: 819

Re: Roof issues

There are some pictures in this thread of where the connector is on my car - they were taken with the hardtop installed - with the hardtop off and roof down, it is much easier to get at. The trim piece is part of the hardtop fitting kit, so you likely won't have this. Also, take a look in the Z3 Kno...
by Robert T
Thu 13 Jun, 2019 22:14
Forum: Z3 roadster
Topic: Roof issues
Replies: 15
Views: 819

Re: Roof issues

You can eliminate the microswitch by disconnecting it and its loom close to where the base of the roof hinges on the left-hand side of the car, and then shorting the same two pins together in the three-way connector on the body. The other pin is for the heated rear-window of the hardtop. The roof up...
by Robert T
Wed 12 Jun, 2019 22:39
Forum: Z3 roadster
Topic: central locking not working
Replies: 20
Views: 7878

Re: central locking not working

I'm glad you've sorted it. If it wasn't the actuator, the next thing to have looked at was the wiring loom between the door and the chassis, as repeated flexation can cause wires to break. Not too bad poking around Z3 electrics, as unless you are dealing with steering wheels or seats, you don't need...
by Robert T
Tue 11 Jun, 2019 00:17
Forum: Z3 roadster
Topic: central locking not working
Replies: 20
Views: 7878

Re: central locking not working

Sounds like the unlock signal to the driver's door is not getting through, or the driver's door actuator is not working. How did you test the wiring/electrics? Also, what happens when you lock and unlock from the boot? This should fire the central locking, the same as using the remote, but the trigg...
by Robert T
Mon 03 Jun, 2019 17:24
Forum: Z3 roadster
Topic: Battery isolator switch
Replies: 2
Views: 307

Re: Battery isolator switch

It was fitted for the journey across the Atlantic and removed after the car arrived in the UK. :?

Cheers R.
by Robert T
Tue 28 May, 2019 22:16
Forum: Boyz Toyz
Topic: 6 CD Changer - No sound
Replies: 8
Views: 554

Re: 6 CD Changer - No sound

The wiring colours are written in shorthand German, e.g. BL is blau or blue not black. If two colours are given, the first is the dominant colour, and the second that of the stripe. The round connector is polarised with a notch at the top and the pin positions should be the same both ends. Did the w...
by Robert T
Tue 28 May, 2019 21:54
Forum: Boyz Toyz
Topic: 6 CD Changer - No sound
Replies: 8
Views: 554

Re: 6 CD Changer - No sound

Okay, I would check the connections on the back of the head unit. Make sure the multichanger is plugged in and look for signs of damage or unconnected wires in the harness. Should be two covers, one each side revealing two Allen bolts. Watch out for the alarm anti-theft switch on the prong at the ba...
by Robert T
Tue 28 May, 2019 21:16
Forum: Boyz Toyz
Topic: 6 CD Changer - No sound
Replies: 8
Views: 554

Re: 6 CD Changer - No sound

No that should be it at the changer end. The 3-way is power and 5-way signal.

Do you get sound from a CD when played in the head unit?

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Tue 28 May, 2019 20:45
Forum: Boyz Toyz
Topic: 6 CD Changer - No sound
Replies: 8
Views: 554

Re: 6 CD Changer - No sound

If you have an ///M roadster, then I would think you have the Harmon Kardon speaker system with the amp in the boot/trunk. If so then I am wondering if you have the wrong connection from the head unit to turn the amp on. I've seen posts on here before where people have got the antenna remote instead...
by Robert T
Tue 28 May, 2019 20:40
Forum: New to zroadster.net?
Topic: New Member
Replies: 2
Views: 250

Re: New Member

Hi and welcome to the forum from me too. :drive:

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Mon 06 May, 2019 21:49
Forum: Z3 roadster
Topic: Alarm issue with starting my Z3
Replies: 4
Views: 469

Re: Alarm issue with starting my Z3

The muted alarm sound is what you get on the early alarms with a separate fob when the power is disconnected and and the siren runs on its backup battery.

Complete loss of power could be many things, but I am thinking possibly a stuck starter motor.

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Thu 02 May, 2019 07:20
Forum: Z3 roadster
Topic: instrument light
Replies: 6
Views: 538

Re: instrument light

Links to various sources for the ETM arein the knowledgebase: viewtopic.php?f=18&t=34176

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Sat 23 Mar, 2019 11:33
Forum: Stock exchange
Topic: Wanted exhaust for my Z3 1.9 Twin Cam
Replies: 14
Views: 1715

Re: Wanted exhaust for my Z3 1.9 Twin Cam

That has to be one of the most bizarre thefts ever - most of the Z3 exhaust systems only fit one model! A new cat is not necessary as expensive as you might think - I recently bought a brand new BM Catalysts one via ebay for £130.52 - described as Catalytic Converter Type Approved BM90418H BM Cats -...
by Robert T
Sat 23 Mar, 2019 11:26
Forum: Z3 roadster
Topic: Z3 1.9 takes time for idle speed to reach correct point.
Replies: 4
Views: 575

Re: Z3 1.9 takes time for idle speed to reach correct point.

This sounds like the behaviour of my car and what I would consider to be "normal". 1300rpm sounds a little high, but it depends upon how well warmed up the engine is - the idle speed gradually reduces as the engine warms up. The two phase reduction in rpm is what I normally see - you pull up and the...
by Robert T
Sat 26 Jan, 2019 11:11
Forum: Z3 roadster
Topic: Info on Instruments wanted please.
Replies: 7
Views: 725

Re: Info on Instruments wanted please.

The speedo in the Z3 is deliberately set to read around 5-10% faster than you are actually travelling. When mine reads 70, the car is actually travelling at about 65mph by the satnav. I am not certain where they build in this "safety factor", but for the mileage not to be significantly skewed, I sus...
by Robert T
Thu 13 Dec, 2018 19:59
Forum: Z3 roadster
Topic: Instrument Cluster
Replies: 6
Views: 1156

Re: Instrument Cluster

I have the same problem with my car every now and again. It is so intermittent (like once every 6 months) that it has so far been impossible to trace. My conclusion thus far is a short or open circuit that causes the cluster to go into safe-mode and not drive the gauges. The rest of the cluster seem...
by Robert T
Mon 10 Dec, 2018 22:46
Forum: Z3 roadster
Topic: Heat at idle
Replies: 9
Views: 1251

Re: Heat at idle

The heater in the Z3 is an air-blender, so on anything but full heat it will blow colder when the water flow through the heater matrix decreases at idle. To solve this, I believe BMW fitted a second, electric, water pump. This makes up for the comparative lack of water flow at idle. More modern BMWs...
by Robert T
Fri 23 Nov, 2018 12:58
Forum: Z3 roadster
Topic: Battery Life
Replies: 5
Views: 1138

Re: Battery Life

The original American battery failed after approx 2 years and was replaced under warranty with one from BMW Germany. This is still on the car over 17 years later. It is not kept on a battery tender. The car is my daily driver and I simply drive the car to keep it charged. Cheers R. Sent from my SM-G...
by Robert T
Tue 20 Nov, 2018 23:58
Forum: Z3 roadster
Topic: Mileometer illumination
Replies: 2
Views: 845

Re: Mileometer illumination

There are two bulbs for that part of the cluster. One illuminates the Service Indicator, the other the mileage display. You need to remove the cluster to get at the back of it to replace the bulbs. There is an article in the knowledgebase that describes how to do that. There are three bulb sizes in ...
by Robert T
Sun 07 Oct, 2018 22:37
Forum: Stock exchange
Topic: Tonneau attaching stud
Replies: 14
Views: 1837

Re: Tonneau attaching stud

Finding the right size might be difficult, but there are lots of other cars out there that have tonneaus or softtops that fit using the same Tenax fasteners. For example my Sprite used smaller ones for both the tonneau and the hood: https://www.moss-europe.co.uk/shop-by-model/austin-healey/sprite/we...
by Robert T
Mon 01 Oct, 2018 19:39
Forum: The Beauty Parlour
Topic: Best windscreen washer fluid
Replies: 3
Views: 743

Re: Best windscreen washer fluid

BMWs own. I but a 5 litre bottle of concentrate and dilute as needed. Good for pretty much all climates. Lasts ages and doesn't seem to go "off" in the tank.

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Sat 08 Sep, 2018 22:30
Forum: Z3 roadster
Topic: Door speakers
Replies: 3
Views: 926

Re: Door speakers

Normal. There were 3 different speaker setups on the Z3, so they made one door card which will accommodate them all. I remember seeing a thread with someone upgrading the tweeters with some orangey ones. Worth hunting out if you want details on upgrade options. Cheers R. Sent from my SM-G950F using ...
by Robert T
Mon 06 Aug, 2018 13:35
Forum: Z3 roadster
Topic: French Speed Limits
Replies: 8
Views: 1439

Re: French Speed Limits

Speedos in modern cars are actually pretty accurate. They are normally set up to overread by a certain amount, thus guaranteeing that you will not be exceeding the speed limit if the needle is showing at the limit. My zed (and many others on this forum judging by previous posts on the subject) reads...
by Robert T
Sun 05 Aug, 2018 00:19
Forum: The Beauty Parlour
Topic: Hood cleaner 83 12 9 408856
Replies: 2
Views: 1173

Re: Hood cleaner 83 12 9 408856

This is what it says on the bottle I have. Same part number. Pump action spray Soft Top Cleaner.

Cheers R.Image

Sent from my SM-G950F using Tapatalk

by Robert T
Thu 26 Jul, 2018 08:38
Forum: Z3 roadster
Topic: Hardtop for sale.
Replies: 10
Views: 1411

Re: Hardtop for sale.

Hardtop is a universal fit to all Z3 roadsters. The only part that differs pre- and post-facelift is the heated rear windscreen switch.

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Thu 19 Jul, 2018 19:54
Forum: Z3 roadster
Topic: 303 frabic proofer
Replies: 3
Views: 826

Re: 303 frabic proofer

I've not used that specific one, but I have used an aerosol proofer several times on mine. The first time I used it, I got some on the glass and it was an absolute pig to get off. Now I mask up using newspaper first. Lower the roof slightly to get it the back edge to protect the rubber. Feed it thro...
by Robert T
Mon 16 Jul, 2018 17:23
Forum: Site Announcements and Feedback
Topic: Donations - zroadster.net
Replies: 6
Views: 6846

Re: Donations - zroadster.net

Donation received with thanks from Uncle_Clanger after being loaned the hardtop tools. Rank now Sponsor 2018.

Thank you.

R.
by Robert T
Sun 15 Jul, 2018 17:42
Forum: Z3 roadster
Topic: Rain getting in again! Has anyone else seen this?
Replies: 3
Views: 847

Re: Rain getting in again! Has anyone else seen this?

What is this "rain" of which you speak? We've had two showers of airborn precipitation in the last 6 weeks. The grass is dust and the trees are starting to lose their leaves! Although the drip is manifesting itself lower down, I would suspect the plug in the end of the rubber where the side window m...
by Robert T
Tue 10 Jul, 2018 19:39
Forum: Z3 roadster
Topic: Hard top rear window
Replies: 2
Views: 582

Re: Hard top rear window

I don't think it is bonded, as there is only a small overlap. If you look on RealOEM/BMWFans, you will see part #17 is a weatherstrip. See http://bmwfans.info/parts-catalog/Z3-Roadster/Europe/Z3_1.9-M44/R-N/jan1999/browse/sliding_roof_folding_top/hardtop_parts/ Cheers R. Sent from my SM-G950F using ...
by Robert T
Fri 06 Jul, 2018 18:18
Forum: Z3 roadster
Topic: Another Central Locking question
Replies: 2
Views: 576

Re: Another Central Locking question

I'd have to go check on mine to be certain, but if my memory serves, the driver's door will not lock whilst it is open, either with the remote or the button. This is a measure to prevent you locking the keys in the car, or worse, leaving them in the ignition and accidentally locking the car with the...
by Robert T
Thu 05 Jul, 2018 14:04
Forum: Z1 roadster
Topic: Rear Lights
Replies: 23
Views: 4411

Re: Rear Lights


bluejay wrote:what does NOS mean?
New Old Stock. Original parts that have sat on a shelf somewhere for years, as opposed to reproduction parts.

Cheers R.



Sent from my SM-G950F using Tapatalk

by Robert T
Wed 27 Jun, 2018 11:31
Forum: Stock exchange
Topic: Phoenix Yellow Z4 3.0 Si Sport Coupe For Sale
Replies: 7
Views: 1538

Re: Phoenix Yellow Z4 3.0 Si Sport Coupe For Sale

Gazza wrote:
Tue 26 Jun, 2018 20:33
Collected today.
Are you starting your own BMW garage, G? :lol:

Cheers R.
by Robert T
Mon 18 Jun, 2018 15:52
Forum: Z3 roadster
Topic: Ground Locations
Replies: 16
Views: 1583

Re: Ground Locations

Cluster electrical problems have cropped up from time to time. There are a few possibilities - it could be a loose multiplug; chafing to the wiring leading up to the cluster; a dry joint or crack in one of the conductors on the PCB. I have had an intermittent problem with mine for many years whereby...
by Robert T
Wed 13 Jun, 2018 19:10
Forum: Z3 roadster
Topic: Z3 1.9 Pre facelift M44 Engine. Lambada probe
Replies: 7
Views: 1292

Re: Z3 1.9 Pre facelift M44 Engine. Lambada probe

CO2 (Carbon Dioxide) or CO (Carbon Monoxide)? Pre-facelift cars did not have a gCO2/km rating, so they are taxed in the over 1.5 litre category, and so I don't think they can test CO2 output. Certainly on my last MOT it just shows CO, HC and lambda. High CO can be that the car was not up to temperat...
by Robert T
Tue 05 Jun, 2018 23:06
Forum: Z3 roadster
Topic: Replacement Seat Bushes Problem
Replies: 3
Views: 695

Re: Replacement Seat Bushes Problem

I take it you have a facelift car? If so, then the yellow piece is a case around three or so smaller connectors. You might be able to remove the case to thread it through.

Have a look in the knowledgebase for some pics.

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Tue 05 Jun, 2018 23:03
Forum: Stock exchange
Topic: Wanted. Rear screen zipper
Replies: 14
Views: 1412

Re: Wanted. Rear screen zipper

Can I have the zipper when you're done? I'll need it for the spare screen I got for my car, but I'd also lend it out like the hardtop tools.

Thanks R.

Sent from my SM-G950F using Tapatalk

by Robert T
Thu 24 May, 2018 19:49
Forum: Z3 roadster
Topic: Headlight wiring query
Replies: 4
Views: 880

Re: Headlight wiring query

The Z3 has a standard wiring harness. The extra connectors will be for options not fitted to your car. Headlight washers, foglights, aircon, marten repelled etc. etc. For your conversion, you really only need to worry about those that are actually connected to something. I would tag them before disc...
by Robert T
Tue 22 May, 2018 19:34
Forum: Site Announcements and Feedback
Topic: I have to sign in almost every time
Replies: 2
Views: 813

Re: I have to sign in almost every time

Might be something to do with my moving the site to https recently. Try clearing your cookies. I've seen issues with old cookies stored under http interfering with new ones stored under https. If that doesn't work, then I will try to find some time to look at it. Cheers R. Sent from my SM-G950F usin...
by Robert T
Thu 10 May, 2018 19:38
Forum: Z3 roadster
Topic: Hood AND brake lights not working
Replies: 5
Views: 1031

Re: Hood AND brake lights not working

Hi Sue, I inhabit the woodwork round here :wink: If it is blowing fuses, then that puts a slightly different slant on it. My guess is that you have a short in the brake lights, most likely in the boot lid wiring loom. It could also be that the switch has failed in such a way as to cause a short ther...
by Robert T
Thu 10 May, 2018 07:54
Forum: Z3 roadster
Topic: Hood AND brake lights not working
Replies: 5
Views: 1031

Re: Hood AND brake lights not working

Hi Sue, Check fuses first, but you are right, the common component to both systems is the switch on the brake pedal. I don't think it is a massive job to change it - garage should do it in less than half an hour. You really don't want to be driving without brakelights. Cheers R. Sent from my SM-G950...
by Robert T
Tue 08 May, 2018 15:33
Forum: Site Announcements and Feedback
Topic: Tapatalk Update
Replies: 1
Views: 962

Re: Tapatalk Update

It's that time again. Tapatalk has been updated to the latest version. I am aware of one issue with the knowledgebase images, which do not work quite the same as when viewed in a web browser. If the images don't display correctly in the app, then select the post and select "Open in browser" from the...
by Robert T
Tue 08 May, 2018 11:44
Forum: Site Announcements and Feedback
Topic: ZRoadster.net is now running on HTTPS
Replies: 2
Views: 676

ZRoadster.net is now running on HTTPS

I have now moved the site over to HTTPS, rather than the old HTTP. For your security, all traffic to and from the site will now be encrypted. You should now see a green padlock in your address bar. Old links starting with http:// should all redirect automatically to their new https:// equivalents. P...
by Robert T
Wed 11 Apr, 2018 19:41
Forum: Computer help
Topic: BM Cables Inpa problems
Replies: 3
Views: 2293

Re: BM Cables Inpa problems

I had to have a bit of a fiddle with the serial port settings for the driver to get it to emulate an appropriate COM port. I can't quite remember what I did. Incidentally, I did get INPA running on Windows 10, but the BMTechnic launcher program no longer works. Just run INPA directly instead. Cheers...
by Robert T
Wed 11 Apr, 2018 00:05
Forum: Let's talk
Topic: It's been a while
Replies: 2
Views: 958

Re: It's been a while

Hi JT. Welcome home. Some of us are still here. My zed is still going strong as my daily driver. Just ticked over 85k for her 19th birthday.
Cheers R :thumb:

Sent from my SM-G950F using Tapatalk


by Robert T
Sat 07 Apr, 2018 19:05
Forum: Z3 roadster
Topic: INPA experts
Replies: 10
Views: 2171

Re: INPA experts

Nice theory, Dave, but I suspect that will not be the case. The entire car already works in metric units - so the speed is measured in kph, fuel consumption in litres etc. The speedo actually receives a different dial on a Euro car, so the KPH scale has the larger numbers - but the positions will be...
by Robert T
Thu 05 Apr, 2018 22:02
Forum: Z3 roadster
Topic: INPA experts
Replies: 10
Views: 2171

Re: INPA experts

Not sure about INPA, as that sounds more like a coding problem than an error or a simple calibration value in the cluster. You can use INPA to simulate a speed in kph, so for example 80 kph should read 50 mph. That way you can see whether gauge has gone haywire. The Speedo is driven by a vaned disc ...
by Robert T
Sat 10 Mar, 2018 09:59
Forum: Computer help
Topic: Private Messages
Replies: 2
Views: 1051

Re: Private Messages

That is the correct behaviour. It just doesn't work like Outlook, that's all. The message will only move from your Outbox to Sent when the recipient logs in.

Cheers R.

Sent from my SM-G950F using Tapatalk

by Robert T
Fri 02 Mar, 2018 23:09
Forum: Z3 roadster
Topic: Alarms yet again
Replies: 2
Views: 1031

Re: Alarms yet again

Check for water in the left hand well in the boot, behind the side trim. The tilt switch sits in the bottom if there and it doesn't like getting wet. It has been known the cause of the alarm going off whilst driving. If it's not that, or you are already having central locking problems, then definite...
by Robert T
Mon 08 Jan, 2018 20:14
Forum: Z3 roadster
Topic: off line for a bit
Replies: 15
Views: 2999

Re: off line for a bit

Really sorry to hear this, Peter. I went through two long sets of chemo treatment nearly 20 years ago, so I know some of what you are going through. Hope the chemo goes well and wish you a speedy recovery.

R.

Sent from my SM-G950F using Tapatalk

by Robert T
Sat 06 Jan, 2018 22:43
Forum: Z3 roadster
Topic: Bloody Alarm!
Replies: 9
Views: 1703

Re: Bloody Alarm!

To my knowledge all UK Z3s from about 09/98 have the same alarm system with the buttons on the key. The interior movement sensor is ultrasonic, but mounted in the centre console. Microwave was only fitted as an upgrade to cars reporting problems with the ultrasonic units. I have the later alarm on m...